Your Time:
Our Time:
← Back to discussions

musicplay and PHP7

Need help with a different issue? Search the forums or open a new ticket.
Open a support ticket

This topic has 4 replies, 3 voices, and was last updated 10 years, 7 months ago by Fem.

  • 2016-02-08 at 1:15 am
    Support Expired
    #12767
    benjaminenfield1
    Participant
    • Topics: 3
    • Replies: 5
    • Total posts: 8
    • Post count: 10

    Hi,

    We recently underwent a test to see how this theme handles making the move to PHP7 within WordPress, which has been available since 4.3 (A wordpress version which says is supported by this theme). However, this is causing a 500 error when trying to access the page.
    After much wasted time, upon removing the theme, the site began to work (all plugins were also disabled etc, so this can only be a problem with the theme).

    Are there plans to upgrade this theme so that it fits with PHP7? As well as removing the depreciation errors which plasters the site when using it?

    This is important as we wish for the server to be at PHP7 for other hosting.

    2016-02-09 at 12:37 am
    Support Expired
    #12800
    benjaminenfield1
    Participant
    • Topics: 3
    • Replies: 5
    • Total posts: 8
    • Post count: 10

    So, after working through this myself, I found out this is caused by two issues.

    The first is business_hours_widget.php. This is contructing WP_Widget with a now end of life Constructor shown below:
    /* Create the widget. */

    $this->WP_Widget( ‘aivah_businesshours_widgets’,’ATP Business Hours’, $widget_ops, $control_ops );

    Changing this too

    /* Create the widget. */

    parent::__construct( ‘aivah_businesshours_widgets’,’ATP Business Hours’, $widget_ops, $control_ops );

    This resolves the worst issue which causes the site to fail entirely.

    The second issue comes from wordplay itself in meta-generator.php in framwork/custom-meta:

    if (!isset($status[‘file’])) {
    continue;
    }

    This is no longer legal outside of a loop, which causes a fatal error in the script.

    For the time being I have changed continue to exit; however, I am concerned that this might not achieve the same result.

    Any thoughts ?

    2016-02-09 at 12:07 pm
    #12807
    Anonymous
    Inactive
    • Topics: 0
    • Replies: 3227
    • Total posts: 3227
    • Post count: 0

    Glad that you have resolved the issues. It is caused due to the called constructor method for WP_Widget which is deprecated. We have fixed this in latest version of this plugin but we forgot to update the plugin. We’ll update the plugin to latest version soon.

    2016-02-13 at 2:29 am
    Support Expired
    #12909
    benjaminenfield1
    Participant
    • Topics: 3
    • Replies: 5
    • Total posts: 8
    • Post count: 10

    Is there any more thought given to the continue issue raised in my post?

    My concern is that my “fix” isn’t a fix and might cause me more issues ?

    2016-02-17 at 6:30 pm
    #12931
    Fem
    Keymaster
    • Topics: 2
    • Replies: 5215
    • Total posts: 5217
    • Post count: 6003

    We will consider taking a look into your another issue and this one tomorrow and let you know.

You must be logged in to reply to this topic.